功能需求

本文档介绍自动AP配置举例。

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解自动AP功能。

组网信息及描述

1所示,AC作为DHCP服务器为AP分配IP地址,现要求使用自动AP功能,实现APAC自动关联,并且在关联后将AP转化为固化AP

配置步骤

1.1  配置步骤

1.1.1  AC的配置

(1)      配置AC接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# 将与Switch相连的接口GigabitEthernet1/0/1的链路类型配置为Trunk禁止VLAN 1通过,允许VLAN 100通过,当前Trunk口的PVID100

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100

[AC-GigabitEthernet1/0/1] quit

(2)      配置DHCP功能

# 开启DHCP服务。

[AC] dhcp enable

# 配置DHCP地址池1AP动态分配的网段为192.1.0.0/16网关地址为192.1.0.1

[AC] dhcp server ip-pool 1

[AC-dhcp-pool-1] network 192.1.0.0 16

[AC-dhcp-pool-1] gateway-list 192.1.0.1

[AC-dhcp-pool-1] quit

(3)      配置自动AP功能

# 开启自动AP功能

[AC] wlan auto-ap enable

# 开启自动AP自动固化功能。

[AC] wlan auto-persistent enable

1.1.2  Switch的配置

# 创建VLAN 100,用于转发ACAPCAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# 配置SwitchAC相连GigabitEthernet1/0/1接口的属性为Trunk,禁止VLAN 1通过,允许VLAN 100通过,当前Trunk口的PVID100

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# 配置SwitchAP相连的GigabitEthernet1/0/2接口属性为Access,当前Access口允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 配置SwitchAP相连的GigabitEthernet1/0/2接口使能PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

1.2  验证配置

# 通过display wlan ap all命令可以看到ACAP建立连接,AP的状态为Run

[AC] display wlan ap all

Total number of APs: 1

Total number of connected APs: 1

Total number of connected manual APs: 1

Total number of connected auto APs: 0

Total number of connected anchor APs: 0

Maximum supported APs: 3072

Remaining APs: 3071

Fit APs activated by license: 512

Remaining fit APs: 511

WTUs activated by license: 500

Remaining WTUs: 500

 

                                 AP information

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup

 

AP name                AP ID   State   Model             Serial ID

--------------------------------------------------------------------------------

741f-4a35-6e00         1       R/M     WA4320-ACN-SI     219801A0T78156A00049

1.3  配置文件

·              AC

#

 dhcp enable

#

 vlan 100

#

dhcp server ip-pool 1

 network 192.1.0.0 mask 255.255.0.0

 gateway-list 192.1.0.1

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk pvid vlan 100

 port trunk permit vlan 100

#

wlan auto-ap enable

 wlan auto-persistent enable

#

·              Switch

#

vlan 100

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

#

配置关键点及注意事项

不涉及

案例信息

案例类型:典型配置
案例号:201606210014
创建时间:2016年6月21日
更新时间:2016年7月14日
发布时间:2016/7/14 7:01:37
文章密级:游客可见
有效期:长期有效
发布者:李晨光 [l08367]
点击次数:1566
评论平均得分:0
关键词:WX,wireless,无线,V7,自动AP
产品线:无线控制器
产品系列:WX5500H系列
产品版本:V7
技术分类:H3C无线局域网(WLAN) 无线基础

常用操作
收藏