功能需求

本文档介绍APAC间通过二层网络完成注册的配置举例。

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WLAN接入相关特性。

组网信息及描述

1所示,集中式转发架构下,无线客户端Client、有线客户端Host通过L2 switchAC相连,L2 switch通过PoE方式给AP供电,AC做为DHCP serverAPClientHost分配IP地址。需要实现无线客户端Client通过AP连接到AC上,并能与有线客户端Host互相访问。

配置步骤

1.1  配置思路

·              AC上开启DHCP server功能,AP、无线客户端Client和有线客户端Host都能通过DHCP server自动获取IP地址。

·              L2 switch上开启PoE功能,为AP设备供电。

·              AC上配置无线服务,确保Client可以通过配置的无线服务接入网络,并访问Host

1.2  配置步骤

1.2.1  配置AC

(1)      配置DHCP server

# 开启DHCP server功能。

<AC> system-view

[AC] dhcp enable

# 配置DHCP地址池1AP分配地址范围为192.168.201.0/24,网关地址为192.168.201.1

[AC] dhcp server ip-pool 1

[AC-dhcp-pool-1] network 192.168.201.0 mask 255.255.255.0

[AC-dhcp-pool-1] gateway-list 192.168.201.1

[AC-dhcp-pool-1] quit

# 配置DHCP地址池2Client分配地址范围为192.168.202.0/24,网关地址为192.168.202.1

[AC] dhcp server ip-pool 2

[AC-dhcp-pool-2] network 192.168.202.0 mask 255.255.255.0 

[AC-dhcp-pool-2] gateway-list 192.168.202.1

[AC-dhcp-pool-2] quit

# 配置DHCP地址池3Host分配地址范围为192.168.203.0/24,网关地址为192.168.203.1

[AC] dhcp server ip-pool 3

[AC-dhcp-pool-3] network 192.168.203.0 mask 255.255.255.0

[AC-dhcp-pool-3] gateway-list 192.168.203.1 

[AC-dhcp-pool-3] quit

(2)      配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.201.1 255.255.255.0

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.168.202.1 24

[AC-Vlan-interface200] quit

# 创建VLAN 300及其对应的VLAN接口,并为该接口配置IP地址。Host使用该VLANAC建立连接。

[AC] vlan 300

[AC-vlan300] quit

[AC] interface vlan-interface 300

[AC-Vlan-interface300] ip address 192.168.203.1 24

[AC-Vlan-interface300] quit

# 配置ACL2 switch相连的接口GigabitEthernet1/0/1Trunk类型,禁止VLAN 1报文通过,允许VLAN 100VLAN 200VLAN 300通过,当前Trunk口的PVID100

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200 300

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

(3)      配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSIDservice

[AC-wlan-st-1] ssid service

# 使能服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

(4)      配置AP

# 创建手工AP,名称为officeap,型号名称为WA4320i-ACN

[AC] wlan ap officeap model WA4320i-ACN

# 设置AP的序列号为210235A1Q2C159000018

[AC-wlan-ap-officeap] serial-id 210235A1Q2C159000018

# 进入APRadio 1视图,将无线服务模板1绑定到Radio 1上,并指定客户端上线的VLANVLAN 200

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan 200

# 开启Radio 1的射频功能。

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] return

1.2.2  配置L2 switch

# 创建VLAN 100VLAN 200VLAN 300,其中VLAN 100用于转发ACAPCAPWAP隧道内的流量,VLAN 200为无线客户端接入的VLANVLAN 300Host接入的VLAN

<L2 switch> system-view

[L2 switch] vlan 100

[L2 switch-vlan100] quit

[L2 switch] vlan 200

[L2 switch-vlan200] quit

[L2 switch] vlan 300

[L2 switch-vlan300] quit

# 配置L2 switchAC相连的接口GigabitEthernet1/0/1Trunk类型,允许VLAN 100VLAN 200VLAN 300通过,当前Trunk口的PVID100

[L2 switch] interface gigabitEthernet 1/0/1

[L2 switch-GigabitEthernet1/0/1] port link-type trunk

[L2 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200 300

[L2 switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[L2 switch-GigabitEthernet1/0/1] quit

# 配置L2 switchAP相连的接口GigabitEthernet1/0/2Trunk类型,禁止VLAN 1报文通过,允许VLAN 100VLAN 200通过,当前Trunk口的PVID100,并开启PoE远程供电功能。

[L2 switch] interfac gigabitEthernet 1/0/2

[L2 switch-GigabitEthernet1/0/2] port link-type trunk 

[L2 switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[L2 switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[L2 switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

[L2 switch-GigabitEthernet1/0/2] poe enable

[L2 switch-GigabitEthernet1/0/2] quit

# 配置L2 switchHost相连的接口GigabitEthernet1/0/3Access类型,允许VLAN 300通过。

[L2 switch] interfac gigabitEthernet 1/0/3

[L2 switch-GigabitEthernet1/0/3] port access vlan 300

[L2 switch-GigabitEthernet1/0/3] quit

1.3  验证配置

(1)      AC上查看AP注册信息

# AC上使用命令display wlan ap all查看AP,可以看到AP的状态是R/M,表明AP已经成功注册到AC

<AC> display wlan ap all                             

Total number of APs: 1                                                         

Total number of connected APs: 1                                               

Total number of connected manual APs: 1                                        

Total number of connected auto APs: 0                                          

Total number of connected anchor APs: 0                                        

Maximum supported APs: 3072                                                    

Remaining APs: 3071                                                             

Fit APs activated by license: 512                                              

Remaining fit APs: 511                                                         

WTUs activated by license: 2500                                                

Remaining WTUs: 2500                                                           

                                                                               

                                 AP information                                

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad       

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup   

                                                                                

AP name                AP ID   State   Model             Serial ID             

--------------------------------------------------------------------------------

officeap               1       R/M     WA4320i-ACN       210235A1Q2C159000018 

(2)      AC上查看Client信息

# AC上使用命令display wlan client查看在线Client,可以看到Client已经连接到APradio1

<AC> display wlan client                                                       

Total number of clients: 1                                                      

                                                                               

MAC address    Username             APID/RID  IP address                 VLAN ID

109a-dd9d-fc68 N/A                     1/1    192.168.202.4              200   

(3)      HostClient可以相互ping

# Client 通过DHCP server获取到IP地址192.168.202.4,在Hostping ClientIP地址可以ping通。同理,在Clientping HostIP地址也能ping通,不再赘述。

C:\Users\system32>ping 192.168.202.4 -t

 

Pinging 192.168.202.4 with 32 bytes of data:

Reply from 192.168.202.4: bytes=32 time=8ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

Reply from 192.168.202.4: bytes=32 time<1ms TTL=255

 

Ping statistics for 192.168.202.4:

    Packets: Sent = 11, Received = 11, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 8ms, Average = 0ms

Control-C

^C

C:\Users\system32>

1.4  配置文件

·              AC

#                                                                              

 dhcp enable                                                                   

#                                                                              

vlan 1                                                                         

#                                                                              

vlan 100                                                                 

#                                                                              

vlan 200                                                                

#      

vlan 300                                                                 

#      

dhcp server ip-pool 1                                                          

 gateway-list 192.168.201.1                                                    

 network 192.168.201.0 mask 255.255.255.0                                      

#                                                                              

dhcp server ip-pool 2                                                          

 gateway-list 192.168.202.1                                                    

 network 192.168.202.0 mask 255.255.255.0                                      

#                                                                              

dhcp server ip-pool 3                                                           

 gateway-list 192.168.203.1                                                    

 network 192.168.203.0 mask 255.255.255.0                                      

#                                                                               

wlan service-template 1                                                        

 ssid service                                                                 

 service-template enable                                                        

#                                                                              

interface Vlan-interface1                                                      

#                                                                               

interface Vlan-interface100                                                    

 ip address 192.168.201.1 255.255.255.0                                        

#                                                                              

interface Vlan-interface200                                                    

 ip address 192.168.202.1 255.255.255.0                                        

#                                                                              

interface Vlan-interface300                                                    

 ip address 192.168.203.1 255.255.255.0                                        

#                                                                              

interface GigabitEthernet1/0/1                                                  

 port link-type trunk                                                          

 undo port trunk permit vlan 1

port trunk permit vlan 100 200 300

port trunk pvid vlan 100                                           

#                                                                              

wlan ap officeap model WA4320i-ACN                                           

 serial-id 210235A1Q2C159000018                                                 

vlan 1

 radio 1                                                                       

  radio enable                                                                 

  service-template 1 vlan 200                                                  

 radio 2  

#                                                                              

·              L2 switch

#                                                                              

vlan 100                                                                        

#                                                                              

vlan 200                                                                       

#                                                                               

vlan 300                                                                       

#                                                                              

interface GigabitEthernet1/0/1                                                  

 port link-type trunk                                                          

 undo port trunk permit vlan 1 100 200 300                                     

port trunk pvid vlan 100

#                                                                               

interface GigabitEthernet1/0/2                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1                                                 

 port trunk permit vlan 100 200                                               

 port trunk pvid vlan 100                                                      

 poe enable

#                                                                               

interface GigabitEthernet1/0/3                                                 

 port access vlan 300                                                          

#                                                                               

配置关键点及注意事项

·              配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·              配置L2 switchAP相连的接口禁止VLAN 1报文通过,以防止VLAN 1内报文过多。

案例信息

案例类型:典型配置
案例号:201606210008
创建时间:2016年6月21日
更新时间:2016年7月10日
发布时间:2016/7/10 12:24:51
文章密级:游客可见
有效期:长期有效
发布者:李晨光 [l08367]
点击次数:1184
评论平均得分:0
关键词:WX,wireless,无线,V7,注册
产品线:无线控制器
产品系列:WX5500H系列
产品版本:V7
技术分类:H3C无线局域网(WLAN) 无线基础

常用操作
收藏