S9500E&S12500伪DHCP服务器检测配置

关键词:
功能需求

        S9500E&S12500DHCP服务器检测配置

一、 组网需求:

二、 问题描述:

如果网络中有私自架设的DHCP服务器,当客户端申请IP地址时,这台DHCP服务器就会与DHCP客户端进行交互,导致客户端获得错误的IP地址,这种私设的DHCP服务器称为伪DHCP服务器,DHCP Server DHCP Relay都是支持伪服务器检测功能。

使能伪DHCP服务器检测功能后,DHCP Server/DHCP Relay 会从接收到的DHCP报文中获取给客户端分配IP地址的服务器IP地址,并记录此IP地址及接收报文的接口信息,以便管理员及时发现并处理伪DHCP服务器。

三、 组网图:

 

l  具有DHCP 中继功能的Switch A 通过端口属于VLAN1连接到DHCP 客户端所在的网络交换机VLAN 接口1 IP 地址10.10.0.1/16 VLAN 接口2 IP地址为10.1.1.2/24

l  DHCP 服务器Switch B IP 地址为10.1.1.1/24

l  网络中存在一台伪服务器Switch C IP 地址为10.10.0.99/16,同客户端在同一个网段。

l  服务器Switch B、中继Switch A 上均开启伪DHCP 服务器检测功能。

l  通过Switch A 转发DHCP 报文DHCP 客户端可以从DHCP 服务器上申请到10.10.0.0/16 网段的IP 地址及相关配置信息。

l  伪服务器Switch C 可以收到客户端发出的Discover 报问并会给客户端分配给客户端分配10.10.0.0/16 网段的IP 地址。

1. 配置步骤

全局使能DHCP功能。

<SwitchB>system-view

[SwitchB]dhcp enable

使能伪DHCP服务器检测功能。

[SwitchB]dhcp server detect

2. 配置文件

dhcp server ip-pool 0

network 10.10.0.0 mask 255.255.0.0

interface Vlan-interface2

ip address 10.1.1.1 255.255.255.0

interface GigabitEthernet2/0/1

port access vlan 2

dhcp server detect

dhcp enable

中继Switch A的配置

1. 配置步骤

 使能DHCP功能。

<SwitchA>system-view

[SwitchA]dhcp enable

 使能伪DHCP服务器检测功能。

[SwitchA]dhcp relay server-detect

 2.配置文件

dhcp relay server-group 1 ip 10.1.1.1

dhcp relay server-detect

interface Vlan-interface1

ip address 10.10.0.1 255.255.0.0

dhcp select relay

dhcp relay server-select 1

interface Vlan-interface2

ip address 10.1.1.2 255.255.255.0

dhcp enable

伪服务器Switch C的配置

1. 配置步骤

全局使能DHCP功能。

<SwitchC>system-view

[SwitchC]dhcp enable

2. 配置文件

dhcp server ip-pool 0

network 10.10.0.0 mask 255.255.0.0

interface Vlan-interface1

ip address 10.10.0.99 255.255.0.0

dhcp enable

1.   验证结果

需要从日志信息中查找伪DHCP服务器。

结果如下

1、 从服务器端Switch A上可以观测到记录

Local DHCP server information: Server IP (detected by DHCP server) =

10.10.0.99, DHCP server interface = Vlan-interface2

2、 从中继Switch B上查询日志记录

DHCP Relay information:DHCP Relay interface = Vlan-interface1,

Server IP (detected by DHCP Relay) = 10.10.0.99

四、 配置关键点:

 

案例信息

案例类型:典型配置
案例号:KMS - 21885
创建时间:2012年8月14日
更新时间:2012年8月14日
发布时间:2012/8/14 4:16:24
文章密级:游客可见
有效期:长期有效
发布者:周涌炜 [zfw0735]
点击次数:292
评论平均得分:0
关键词:
产品线:低端交换机
产品系列:
产品版本:
技术分类:网络层协议 IPSec

常用操作
收藏