WX系列AC实现Remote AP功能的配置

关键词:
功能需求

WX系列AC实现Remote AP功能的配置

一、 组网需求:

WX系列ACFIT AP、交换机、便携机(安装有无线网卡)、DHCP Server

二、 组网图:

本配置举例中的AC使用的是WX5004无线控制器,APDHCP Server上通过DHCP方式获取IP地址,并与AC建立连接。

ACVLAN1接口IP地址为192.168.0.100/24AP通过VLAN100AC进行关联,无线客户端关联后属于VLAN 50

AP提供本地转发的SSIDRemoteAP”,在APAC之间的链路断开后,由于AP启用了Remote AP功能,此AP将继续提供“RemoteAP”的无线服务。

三、 特性介绍:

Remote AP功能推荐与AP的本地转发特性共同使用,可提供集中认证、本地转发的WLAN服务。

Remote AP支持各种认证方式,包括ClearShared KEY802.1XPortal认证等。不论用户通过这些认证中的哪一种,在Remote APAC断开连接后,都能继续访问本地网络资源。

Remote AP是一种针对远程办公、小的分支机构或家庭办公的解决方案。通过Remote AP,客户能够在公司总部统一部署和管理通过Internet网络连接的远程办公室或小的分支机构的AP,而不需要在这些地方单独部署一个无线控制器。

四、 主要配置步骤:

# 配置AP管理VLAN接口及其IP地址。

[AC] system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface Vlan-interface 100

[AC-Vlan-interface100] ip address 8.50.1.54 255.255.0.0

[AC-Vlan-interface100] quit

# 配置无线业务VLAN接口及其IP地址。

[AC] vlan 50

[AC-vlan50] quit

[AC] interface Vlan-interface 50

[AC-Vlan-interface50] ip address 50.1.1.54 255.0.0.0

[AC-Vlan-interface50] quit

# 配置无线接口。

[AC] interface WLAN-ESS 1

[AC-WLAN-ESS1] port link-type hybrid

[AC-WLAN-ESS1] port hybrid vlan 1 50 untagged

[AC-WLAN-ESS1] port hybrid pvid vlan 50

[AC-WLAN-ESS1] mac-vlan enable

[AC-WLAN-ESS1] quit    

# 配置无线服务模板,开启SSID的本地转发特性。

[AC] wlan service-template 1 clear

[AC-wlan-st-1] ssid RemoteAP 

[AC-wlan-st-1] bind WLAN-ESS 1

[AC-wlan-st-1] client forwarding-mode local vlan 50

[AC-wlan-st-1] service-template enable

 Please wait... Done.

[AC-wlan-st-1] quit

# ACAP视图下配置AP名称为ap0,型号名称这里选择WA2220-AG

注:请根据AP的实际型号和序列号进行配置。

[AC] wlan ap ap0 model WA2220-AG

[AC-wlan-ap-wa2210] serial-id 210235A42WC10B000442

# 开启Remote AP功能。

[AC-wlan-ap-wa2210] hybrid-remote-ap enable

# 通过map文件对Fit AP下发配置。

[AC-wlan-ap-wa2210] map-configuration wa2200mapcfg.txt

# map文件中的内容如下:

<AC>more wa2200mapcfg.txt

vlan 50

interface Ethernet 1/0/1

port link-type trunk

port trunk permit vlan all

# 进入APradio1射频视图,配置AP的工作信道,配置服务模板与射频进行关联,使能APradio1射频。

[AC-wlan-ap-wa2210] radio 1

[AC-wlan-ap-wa2210-radio-1] channel 6

[AC-wlan-ap-wa2210-radio-1] service-template 1 vlan-id 50

[AC-wlan-ap-wa2210-radio-1] radio enable

# 交换机L3 switchAP连接的端口GE1/0/2上需要配置允许对应的VLAN通过,并设置PVID。交换机L3 switchAC连接的端口GE1/0/1也需要进行对应的配置,这里不再一一列举。

[LSW-GigabitEthernet1/0/2]display this

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan all

 port trunk pvid vlan 100

#

 

五、 结果验证:

(1)    无线客户端关联上线。

[AC]display wlan client

 Total Number of Clients           : 1

                               Client Information

 SSID: RemoteAP

-------------------------------------------------------------

MAC Address    User Name            APID/RID IP Address                     VLAN

-------------------------------------------------------------

0013-ceb5-f462 -NA-                 1   /2    50.1.1.15                        50  

(2)    APAC正常关联的状态,AC与无线客户端之间通信正常。

<AC>ping 50.1.1.15

  PING 50.1.1.15: 56  data bytes, press CTRL_C to break

    Reply from 50.1.1.15: bytes=56 Sequence=1 ttl=128 time=3 ms

    Reply from 50.1.1.15: bytes=56 Sequence=2 ttl=128 time=2 ms

    Reply from 50.1.1.15: bytes=56 Sequence=3 ttl=128 time=1 ms

    Reply from 50.1.1.15: bytes=56 Sequence=4 ttl=128 time=2 ms

    Reply from 50.1.1.15: bytes=56 Sequence=5 ttl=128 time=1 ms

 

  --- 50.1.1.15 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

round-trip min/avg/max = 1/1/3 ms

(3)    关闭ACVLAN100接口,使得APAC之间的隧道链路断掉。

[AC] system-view

[AC] interface Vlan-interface 100

[AC-Vlan-interface100] shutdown

此时AP仍然发送Beacon帧,无线客户端不会掉线,仍然能够访问局域网内部的资源。

 

案例信息

案例类型:典型配置
案例号:KMS - 21371
创建时间:2012年6月25日
更新时间:2012年6月26日
发布时间:2012/6/26 4:12:36
文章密级:游客可见
有效期:长期有效
发布者:宋斌 [s05097]
点击次数:903
评论平均得分:0
关键词:
产品线:无线终端
产品系列:
产品版本:
技术分类:H3C无线局域网(WLAN) MPLS

常用操作
收藏