功能需求

Typical Configuration Of OSPF Imported Route Summary on AR28AR46 Series Routers

[Requirements]

In an OSPF AS, Routers A and B run in area 0; Routers B and C run in area 1; Router B serves as the ABR.

Two Ethernet interfaces of Router C are located in area 1, respectively belonging to 40.1.1.0/24 and 40.1.2.0/24 network segments. They are imported to the OSPF through import direct.

It is required to perform route summary on the ASBR to summarize the above two segments to 40.1.0.0/16.

[Networking diagram]

[Configuration script]

Configuration script on Router A

#

sysname RouterA

#

router id 1.1.1.1

#

radius scheme system

#

domain system

#

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

#

interface Serial0/0

link-protocol ppp

ip address 20.1.1.1 255.255.255.252

#

interface NULL0

#

interface LoopBack0

ip address 1.1.1.1 255.255.255.255

#

ospf 1

area 0.0.0.0

network 1.1.1.1 0.0.0.0

network 10.1.1.0 0.0.0.255

network 20.1.1.0 0.0.0.3

#

user-interface con 0

user-interface vty 0 4

#

return

Configuration script on Router B

#

sysname RouterB

#

router id 1.1.1.2

#

radius scheme system

#

domain system

#

interface Seria0/0

link-protocol ppp

ip address 20.1.1.2 255.255.255.252

#

interface Serial0/1

link-protocol ppp

ip address 30.1.1.1 255.255.255.252

#

interface NULL0

#

interface LoopBack0

ip address 1.1.1.2 255.255.255.255

#

ospf 1

area 0.0.0.1

network 30.1.1.0 0.0.0.3

#

area 0.0.0.0

network 1.1.1.2 0.0.0.0

network 20.1.1.0 0.0.0.3

#

user-interface con 0

user-interface vty 0 4

#

return

Configuration script on Router C

#

sysname RouterC

#

router id 1.1.1.3

#

radius scheme system

#

domain system

#

interface Ethernet0/0

ip address 40.1.1.1 255.255.255.0

#

interface Ethernet0/1

ip address 40.1.2.1 255.255.255.0

#

interface Serial0/0

link-protocol ppp

ip address 30.1.1.2 255.255.255.252

#

interface NULL0

#

interface LoopBack0

ip address 1.1.1.3 255.255.255.255

#

ospf 1

asbr-summary 40.1.0.0 255.255.0.0  /Summarize the imported route/

import-route direct                /Import the direct route for the interface/

area 0.0.0.1

network 1.1.1.3 0.0.0.0

network 30.1.1.0 0.0.0.3

#

user-interface con 0

user-interface vty 0 4

#

return

 

[Verification]

Routers can learn the routes of the whole network through OSPF, and their network segments can be pinged mutually.

Routing table of Router A:

<RouterA>disp ip rout

Routing Table: public net

Destination/Mask   Protocol Pre  Cost        Nexthop         Interface

1.1.1.1/32         DIRECT   0    0           127.0.0.1       InLoopBack0

1.1.1.2/32         OSPF     10   1563        20.1.1.2        Serial0/0

1.1.1.3/32         OSPF     10   3125        20.1.1.2        Serial0/0

10.1.1.0/24        DIRECT   0    0           10.1.1.1        Ethernet0/0

10.1.1.1/32        DIRECT   0    0           127.0.0.1       InLoopBack0

20.1.1.0/30        DIRECT   0    0           20.1.1.1        Serial0/0

20.1.1.1/32        DIRECT   0    0           127.0.0.1       InLoopBack0

20.1.1.2/32        DIRECT   0    0           20.1.1.2        Serial0/0

30.1.1.0/30        OSPF     10   3124        20.1.1.2        Serial0/0

30.1.1.1/32        O_ASE    150  1           20.1.1.2        Serial0/0

40.1.0.0/16        O_ASE    150  2           20.1.1.2        Serial0/0

127.0.0.0/8        DIRECT   0    0           127.0.0.1       InLoopBack0

127.0.0.1/32       DIRECT   0    0           127.0.0.1       InLoopBack0

 

[Tip]

1. In an ordinary area, it is not allowed to summarize the imported routes on the ABR but on the ASBR.

2. In an NSSA area, it is allowed to summarize the imported routes on the ABS.

3. When summary of imported route is configured, the local router serving as the ASBR will summarize the imported Type-5 LSAs in the summary address scope. When the NSSA area is configured, the local router will also summarize the imported Type-7 LSAs in the summary address scope.

4. The local router, if serving as the ABR and the conversion router of NSSA area, will summarize the Type-5 LSAs converted from Type-7 LSAs.

案例信息

案例类型:典型配置
案例号:KMS - 12563
创建时间:2007年9月17日
更新时间:2007年9月30日
发布时间:2007/9/30 3:40:36
文章密级:游客可见
有效期:长期有效
发布者:沈杨豪 [s05096]
点击次数:584
评论平均得分:0
关键词:
产品线:中低端路由器
产品系列:
产品版本:
技术分类: VPN

常用操作
收藏